• sales

    +86-0755-88291180

WAVEGO-Development Environment Configuration

Development Environment Setup

Introduction

  • This chapter mainly introduces the development environment setup for WAVEGO on the Arduino IDE. By studying this chapter, you can begin your development journey for the WAVEGO slave ESP32.

Install Arduino IDE

  1. First, go to Arduino official website to download the installation package of the Arduino IDE.

  2. Once the download is complete, click Install.

    Notice: During the installation process, it will prompt you to install the driver, just click Install

Arduino IDE Interface

  1. After the first installation, when you open the Arduino IDE, it will be in English. You can switch to other languages in File --> Preferences, or continue using the English interface.

  2. In the Language field, select the language you want to switch to, and click OK.

Installing ESP32 Plugin in Arduino IDE

  1. Open the Arduino IDE, click on the file in the top left corner, and select Preferences

  2. Add the following link to the attached board manager URL, and then click OK
    https://dl.espressif.com/dl/package_esp32_index.json


    Note: If you already have an ESP32 board URL, you can use a comma to separate the URLs as follows:

    https://dl.espressif.com/dl/package_esp32_index.json,http://arduino.esp8266.com/stable/package_esp8266com_index.json
  3. Download packages package, and copy the extracted packages folder to the following path
    C:\Users\xutong\AppData\Local\Arduino15


    Note: Replace the username: xutong with your own username

Install Dependency Libraries

  • Download and extract the Libraries dependency library. Open the default Arduino installation location C:\Users\xutong\AppData\Local\Arduino15\libraries (based on your actual location), and then copy these folders to Libraries

Upload Demo

  1. Download WAVEGO open-source demo (Arduino), double-click Arduino\WAVEGO\WAVEGO.ino

  2. Click Tools --> Port, remember the existing COM, do not click this COM (the COM displayed is different on different computers, remember the COM on your own computer)

  3. Connect the driver board to the computer using a USB cable. Then, go to Tools > Port, and click the newly appeared COM

  4. Click Tools > Development Board > ESP32 Arduino > ESP32 Dev Module


  5. Click Tools, and the other settings are as follows (it is best to set Partition Scheme as Huge APP, and PSRAM must be set to Enabled, otherwise the camera will flash black):

  6. Once all settings are configured, click "Upload" to upload the demo to the device

  • If issues arise during this period, and if you need to reinstall or update the Arduino IDE version, it is necessary to uninstall the Arduino IDE completely. After uninstalling the software, you need to manually delete all contents within the C:\Users\[name]\AppData\Local\Arduino15 folder (you need to show hidden files to see this folder). Then, proceed with a fresh installation.

All Tutorials

Resources

Robot Diagram

Open Source Resources

Raspberry Pi Learning Resources

TAG: Screen ESP32-S3 7inch LCD Display 7 inch TouchScreen 7B 1024×600 N16R8 CAN RS485 Sensor ESP32 0.85inch LCD Mini TOF Time-of-Flight Laser Ranging Radar Sensor Compatible with Arduino Raspberry Pi ESP32 and Pico ESP32-S3 AI Camera 1.28inch LCD Dual MIC Development Board Display 1.28 inch Voice Interruption Object Recognition 10-in-1 Multifunctional UPS HAT D Raspberry Pi Pico 2 Plus RP2350 Board RP2350A Raspberry Pi Compute Module 4 CM4 PCIe to M.2 NVMe SSD Raspberry Pi 5 PCIe to M.2 NVMe SSD Adapter Board (D) HAT Pi5-2280-2242-2230 AV to TTL ESP32-P4-WIFI6 3.5inch LCD Display AI Development Board 320×480 3.5 inch TouchScreen Deepseek Arducam RS232 to Ethernet Raspberry Pi PICO Long-Range Communication ESP32-P4 Smart 86 TV Box Development Board 4 inch 720x720 Display TouchScreen RS485 Relay Camera RJ45 ETH Raspberry Pi Pico 2 RP2350 ETH CH9120 TCP/UDP Ethernet Network For Arduino ESP32 ST7789 Solar DeepSeek AI Voice Chat Robot ESP32 S3 Development Board 2.8 inch Display 2.8inch Screen USB to JTAG